Memsource Web Editor User Manual

From Memsource
Jump to: navigation, search

Introduction

Memsource Web Editor is our completely web-based translator's workbench. It is available to all Memsource subscribers. No installation or any other special PC settings are needed and it can also be used on tablets. Unlike the desktop Memsource Editor, it cannot be used when a user is offline. If your Internet connection is not stable and fast, please use desktop Memsource Editor instead. Using Memsource Web Editor is recommended for smaller jobs up to 10 000 segments (40 000 segments is the limit).

Linguist Users

Linguist users may use Memsource Web Editor if it has been enabled for them via Web Editor enabled for linguists under Setup - Access and Security (if you change this setting, the change will only be effective for newly created projects). This global setting is selected by default for all organizations that have subscribed to Memsource after 18 May 2014. There is a similar setting for existing projects under project settings' Access & Security section.

Keyboard Shortcuts

A complete list of keyboard shortcuts in Memsource Web Editor is available here: Keyboard Shortcuts page

Web Editor Commands

Commands can be launched either from the menu, quick access buttons at the top of the application or through keyboard shortcuts.

Edit Menu

Edit menu

Confirm (Ctrl+Enter)

  • Confirms segment as translated and saves it into TM. It is recommended to confirm every segment right after translating it. Confirming all segments in a batch can cause problems in larger jobs.

Unconfirm (Ctrl+Shift+Enter)

  • Unconfirms a segment

Copy Source to Target (Ctrl+Insert or Cmd+Shift+I on Mac)

  • Copies text in the source segment to the target segment and also works for any selection of the source text

Delete Target Text (Ctrl+D)

  • Deletes text in the target segment based on the following:
    • If the segment is selected (by clicking on the segment number), the entire content of the segment will be deleted
    • If the cursor is placed at the beginning or end of a segment, the entire content of the segment will be deleted
    • If the cursor is placed anywhere else in the segment, this command will delete everything after the cursor
Tags
Insert Tag (F8)
  • Insert tags; when inserting {1>paired tags<1}, first select the text to get enclosed in tags and only then hit the Insert Tag command. In this way both tags will be inserted at once around the selected text.
Insert All Tags (Ctrl+Shift+F8)
  • Insert all tags from the source segment at the cursor position in the target segment.
Create Custom Tag (Alt+F8)
  • Creates an arbitrary unpaired tag in the target (supported for XLIFF, HTML and XML source files)
Create Custom Paired Tag (Alt+Shift+F8)
  • Creates an arbitrary paired tag in the target (supported for XLIFF, HTML and XML source files)
Expand Tags (Ctrl+Shift+E)
  • Expands tags and displays the tag content (supported for XLIFF, HTML and XML source files)
Remove All Tags (Ctrl+F8)
  • Remove all tags from the target

Toggle Case (Shift+F3)

  • Toggles upper case to lower case and vice versa
Insert symbol
Insert Non-breaking Space (Ctrl+Shift+Space)
  • Inserts a non-breaking space
Insert Non-breaking Hypen
  • Inserts a non-breaking Hypen
Insert New Line (Shift+Enter)
  • Inserts a line break

Undo (Ctrl+Z)

  • Undo last action

Redo (Ctrl+Y)

  • Redo last action

Split Segment (Ctrl+E)

  • Splits a segment in two, the cursor has to be in the source segment to split

Join Segment (Ctrl+J)

  • Joins the selected segment with the segment below

Lock/Unlock Segment (Ctrl+L)

  • Locks or unlocks the selected segment (this option is not available for Linguists)

Repetition Exception

Select All Segments (Ctrl+Shift+A)

  • Selects all segments
CAT Results
CAT Results Move Up (Ctrl+ArrowUp or Cmd+Up on Mac)
  • Moves the cursor up to the next result in the CAT pane
CAT Results Move Down (Ctrl+ArrowDown or Cmd+Down on Mac)
  • Moves the cursor down to the next result in the CAT pane
CAT Results Insert (Ctrl+Space or Cmd+Ctrl+Space on Mac)
  • Inserts the selected TM or TB match in the appropriate segment
CAT Results Insert from
  • E.g. Ctrl+1 to insert match no. 1 in the appropriate segment

Move to First Segment (Ctrl+Home)

  • Moves the cursor to the first segment

Move to Last Segment (Ctrl+End)

  • Moves the cursor to the last segment

Toggle Cursor Source/Target (Ctrl+Tab)

  • Moves cursor between source and target

Edit Source (F2)

  • Press to edit the source text (e.g. where a typing error needs to be corrected)

Edit Comment (Ctrl+M)

  • Press to edit comment

Tools Menu

Tools menu

Filter (Ctrl+Shift+F)

  • Filters segments with the selected text

Add Term (Alt+T)

Search* TM/TB (Ctrl+K)

  • Searches the project translation memories and term bases for the selected word or phrase using wildcard search

Search TM/TB (Ctrl+Shift+K)

  • Searches the project translation memories and term bases for the selected word or phrase using the exact search (in quotes)

Spellcheck (F7)

  • Launches spellchecker

Context Note (Atl + N)

  • Show/hide Context window at the bottom of the Editor.

Preview (Offers real-time preview of the translated segment. Available only for specific file formats: Microsoft Word, HTML, XML with XSL template and DITA.)

  • Disable
  • Source
  • Target

Go to Segment (CTRL+G)

  • Jumps to segment with the specified number

Preferences opens Preferences window

  • CAT tab:
    • Set the Minimum match rate for translation memory matches to get displayed and used for pre-translation
    • Select the desired behavior after confirming a segment (e.g. if Next unconfirmed segment is selected, the cursor will automatically jump to the next unconfirmed segment after confirming a segment)
    • Set the Pre-translate options, which control the behavior of pre-translating the next segment that the user jumps to after confirming a previous segment
    • Select Insert machine translation to have segments pre-translated with the machine translation when a translation memory match above the minimum specified threshold is not available. Please note that this option will only work if the machine translation has been activated for the project by the project manager
  • Appearance tab:
    • Select the font size of the translation table and the panes
  • Misc tab:
    • Enable Auto-complete

Format Menu

Format menu

Bold

  • Ctrl+B

Italic

  • Ctrl+I

Underline

  • Ctrl+U

Subscript

  • Ctrl+-

Superscript

  • Shift+Ctrl+_

Quotation

Show spaces

  • Toggle to display hidden characters (such as space, non-break space, new line)

Document Menu

Document menu

View Original

  • Opens the original (source) file

Preview Translation

  • Opens the translated (target) file

Preview PDF

  • Opens the translated (target) file as PDF - available only for IDML files with Frontlab Integration

Export to Bilingual MXLIFF

  • MXLIFF can be opened in desktop version of Memsource Editor

Export to Bilingual DOCX

  • Bilingual DOCX can be opened and edited in MS Word

Import from Bilingual DOCX

  • Imports data from Memsource Bilingual DOCX back to Memsource server

View Project

  • Opens the project

Text Filter (Find and Replace)

Find and replace

Find

To find words in the source or target, use the text filter.

Exact search (using quotes) is not available in the Web Editor (only in the Desktop Editor).

Replace

To replace or replace all, proceed as follows:

  1. Enter the words you need to replace in the text filter
  2. After you have entered the word(s) in the filter, expand the additional segment filter options and then expand the Replace menu
  3. Now you can use the Replace or Replace All features

Segment Filter and Sorting

The segment filter is expanded by clicking on the triangle icon at the top left of the Memsource Editor. By selecting any of the filter options, the appropriate segments are filtered. Multiple filter options can be combined, including with the text filter.

Segment Status

Segment filter

Select one or more of the options below to filter the segments with the desired status:

  • Empty
  • 1st Repetition
  • Rep. Exception
  • Confirmed
  • Not Confirmed
  • Edited
  • Not Edited
  • Locked
  • Not Locked
  • Resolved Comments
  • Not Resolved (Comments)

Pre-translated From

These will filter segments based on their initial pre-translation method:

  • 101%
  • 100%
  • Fuzzy
  • MT
  • Non-translatables

Created By / Modified By

Filter segments based on which the user created them or last modified them; Track changes between workflow steps:

  • Segments Created By
  • Segments Last Modified By
  • Comments Created By
  • Comments Last Modified By
  • Show Changes

Segment Sorting

Select one of the options below to sort segments:

  • No Sort
  • Source A to Z (to sort segments by source from A to Z)
  • Source Z to A (to sort segments by source from Z to A)
  • Shortest First
  • Longest First
  • Least Repetitions
  • Most Repetitions

Conversation

Comments and LQA

Conversations can be used to create thread-like communication with all users involved in the assignment. Apart from creating general comments for the entire segments, users can also comment only on specific parts of the segment, e.g. a phrase. Press the icon next to each segment where you can:

  • Add a comment
  • Reply to an existing comment
  • Edit or delete comments
  • Resolve comments

Comments are a part of Quality Assurance check for Unresolved Conversation which will be displayed if any of the comments inside a conversation will remain Unresolved when the QA is run. In projects with workflow, comments are automatically pushed into both higher steps (similar to translations), but also lower steps.

LQA

Apart from adding comments, projects with workflow can also utilize Language Quality Assessment feature of conversations. Similar to the comments, it is possible to leave LQA evaluation per segment or its parts to provide feedback. The following LQA categories are available:

  • Accuracy
  • Fluency
  • Terminology
  • Style
  • Design
  • Locale convention
  • Verity
  • Other

Each of these categories can then be set to various levels of severity: Neutral, Minor, Major, Critical.

Spellchecker

Internal Spellchecker

Spellchecker

Memsource Web Editor has an integrated spellchecker that supports 141 languages.

Launch Spellchecker

The spellchecker is launched by the F7 key or from the Tools menu. It will list all spelling errors in the QA pane. After correcting the misspelled word and confirming the segment, the user will be taken to the next segment with the misspelled words.

Inline Spellchecking

A curly red line underlines the misspelled words.

Alternative Spellings

Right-clicking on a misspelled word will display a list of alternative spellings.

Add to Dictionary

Clicking on the red arrow icon under the misspelled word will allow a user to add the word to the user's dictionary. (It will soon be possible to edit a user's dictionary.)

Ignore

To ignore a word without adding it to the dictionary, click in the "i" section in the QA pane. Doing this will show the misspelled word as "ignored" under QA but the word itself will remain underlined in the target segment.

MS Word Spellchecker

Any translation job can also be spellchecked in an external application that supports DOCX files, such as MS Word or Open Office Writer:

  1. Go to a Memsource Cloud project with the translation job you plan to spellcheck. Select the job and click on Download - Bilingual DOCX
  2. Open the bilingual DOCX file in e.g. MS Word, run the spellcheck and do not forget to save the file afterwards
  3. Return to your Memsource Cloud project and click on Tools - Upload to upload the spellchecked bilingual MS Word file
  4. After the upload, open your job in Memsource Web Editor and confirm all not confirmed segments (e.g. by using the filter function)

Repetitions

When a segment is repeated in a document, it is called a repetition. A repetition can be easily identified in Memsource Web Editor, as blue arrows are displayed next to the repeated segment.

Once a user confirms a repeated segment, all the repeated instances of that segment below it will be updated with the confirmed translation. Please note that repetitions are only propagated downwards.

Repetition Exception

Sometimes it is necessary to introduce a "repetition exception," which allows a repeated segment to have a different translation than all the other repeated segments. This can be done by clicking on the repetition icon, which will become crossed. This will ensure that a translation for such a segment will not change in line with the other repetitions.

Auto-complete

Autocomplete

The auto-complete feature will help you type faster by offering you words from the Right CAT Pane (results from TM, MT and TB), based on the characters you type.

  • Press the Up and Down Arrows to select from the list
  • Press TAB or ENTER to add a selected word from the list (the first one is always pre-selected) to the target segment
  • Press Esc to hide Auto-complete Windows (it will re-appear after you press any key)

Only 3 words are offered - the list will get more precise with every new character written. This feature is not offered for non-space languages (Chinese, Japanese, Korean)

The Auto-complete can be turned off in Tools -> Preferences -> Mics -> Enable Auto-complete. The Preference settings are saved in the opened web browser.

Panes

CAT Pane

CAT pane

The CAT pane displays matches for each segment, when available, from:

  • Translation memory
    • 101% matches. These are higher than 100% matches, since the context also matches to what is saved in the TM. See this section for more about TM context
    • 100% matches
    • Fuzzy matches
    • Subsegment matches
  • Term base
    • New terms (created by linguist users)
    • Approved terms (An asterisk notifies users about term Note or Usage information.)
    • Rejected terms (displayed in red color)
  • Machine translation
    • If enabled by the project manager

More details here.

Search Pane

Search pane

The search pane displays the results for search queries from:

  • The translation memory
  • The term base

The search can be launched by selecting some text in the source or target and hitting:

  • Ctrl+K for a fuzzy search
  • Ctrl+Shift+K for an exact search

QA Pane

Quality assurance pane

The quality assurance pane displays QA warnings for segments with problems, as identified by QA.

The QA warnings should be either resolved by correcting the translation and confirming it or by marking the QA warning as ignored (by clicking in the "i" column) if the QA warning is a false alarm, for instance. Here is a list of the available QA checks:

  • Empty translation
  • Trailing punctuation
  • Inconsistent translations
  • Missing numbers
  • Multiple spaces
  • Trailing spaces
  • Tags & formatting
  • Inconsistent tag content
  • Empty tag content
  • Tags - joined segments
  • No text between tags
  • XLIFF tags
  • Terminology
  • Unconfirmed segments
  • Unresolved comments
  • Maximum segment length in characters
  • Not allowed characters

Changes Pane

Changes Pane displays changes in a segment across all workflow steps. The Show Changes feature is only available for jobs with Workflow (Editions Team and Ultimate). If no changes are available or workflow is not active for the given file, the Changes pane will be blank.

The Show Changes filter can only be used to filter segments that have changes.