Memsource Cloud System Requirements

From Memsource

Jump to: navigation, search

A reliable internet connection and a web browser is needed to connect to and use Memsource Cloud.

Two most recent versions of Google Chrome, Firefox, Safari, and Internet Explorer are supported.

Recommended minimum configuration for reliable performance:

Personal tools
Namespaces
Variants
Actions
Getting Started
Memsource Cloud
Memsource Editor
Web Editor
Toolbox